This large document requires a relatively recent version of Adobe. It works on Adobe 8 or 9, but does not work on Adobe 5.